Trading, Deposits & Withdrawals for NXRA temporarily unavailable
Incident Report for Uphold
Monitoring
Withdrawals have been reinstated. Deposit and Trading NXRA remain suspended due to insufficient liquidity.

Full support for NXRA will be reinstated as soon as market conditions allow.
Posted Aug 19, 2024 - 15:07 UTC
Investigating
Due to a security concern on the Nexera Network the chain is currently halted. As such NXRA deposits and withdrawals are disabled. Team is monitoring with the Nexera Foundation to resume regular processing.
Posted Aug 07, 2024 - 08:29 UTC
This incident affects: Deposits & Withdrawals.