We're experiencing failures on Uphold Card transactions.
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted May 17, 2021 - 15:44 UTC
Monitoring
Our provider was able to apply a fix and we're now monitoring the system.
Posted May 15, 2021 - 09:24 UTC
Investigating
We're working with our provider to identify the root cause and work on a fix.
Posted May 14, 2021 - 10:10 UTC
This incident affected: Uphold Debit Card (Uphold Debit Card).