Issues with the Cardano Blockchain
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 14:16 UTC
Monitoring
Fireblocks's processing infrastructure is currently experiencing an issue with finalizing transactions on the Cardano blockchain. More information can be found on their status page here: https://status.fireblocks.com/incidents/32m2vllmlwpw
Posted Nov 19, 2024 - 12:21 UTC