Uphold Card downtime
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Jul 13, 2022 - 18:38 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 18, 2022 - 15:27 UTC
Monitoring
We're gradually restoring service to the US debit card and continue to monitor the situation.
Posted Jun 18, 2022 - 15:26 UTC
Investigating
We’re experiencing some technical difficulties and have had to temporarily suspend transactions on our US debit card.
Posted Jun 15, 2022 - 13:34 UTC
This incident affected: Uphold Debit Card (Uphold Debit Card).