DASH Deposits & Withdrawals
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Sep 14, 2022 - 10:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2022 - 09:41 UTC
Investigating
We are unable to process DASH deposits and withdrawals via crypto network. We're investigating the issue.
Posted Sep 14, 2022 - 09:04 UTC
This incident affected: Crypto (Dash).