We're experiencing delays sending email, examples are the "Verify it's you" or "Reset 2FA" emails. There is no impact on the wallet.
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Nov 09, 2022 - 19:26 UTC
Investigating
We are currently investigating this issue.
Posted Nov 09, 2022 - 17:15 UTC