Identity verification provider downtime
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Jul 06, 2024 - 00:17 UTC
Identified
Our partner has identified the issue and a fix is being implemented.
Posted Jul 05, 2024 - 15:02 UTC
Update
We are continuing to investigate this issue.
Posted Jul 05, 2024 - 14:11 UTC
Investigating
TEMPORARY DISRUPTION: Our Identity screening partner is experiencing issues which may result in the inability to conclude Identity Verification and Selfie Checks.

We apologize for this inconvenience and assure you that we're working with our provider to restore service.
Posted Jul 05, 2024 - 14:08 UTC
This incident affected: Mobile Wallet, Web Wallet, and Deposits & Withdrawals.