Alephium blockchain increased block times

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 09:55 UTC

Investigating

Earlier today, the Alephium network began experiencing significantly increased block times due to a sudden spike in difficulty.

We are working on a solution with the Alephium team.

Deposits via Alephium have been disabled and withdrawals may experience delays due to uncertain block production times.
Posted Jul 25, 2025 - 23:30 UTC
This incident affected: Deposits & Withdrawals.