Delayed Crypto Transactions

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 10:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 26, 2025 - 03:16 UTC

Investigating

We’re addressing a technical issue that’s temporarily affecting crypto withdrawals on Uphold {and Topper}.

We're on it and expect to restore full service shortly.

We’ll post regular updates here as more information becomes available.

Thank you for your patience and understanding. We apologize for any inconvenience.
Posted Oct 26, 2025 - 02:39 UTC
This incident affected: Deposits & Withdrawals, API, and Topper.