We are experiencing delays in processing Ethereum and ERC-20 deposits.
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Feb 01, 2021 - 22:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 01, 2021 - 18:04 UTC
Investigating
We are currently investigating this issue.
Posted Feb 01, 2021 - 14:29 UTC
This incident affected: Crypto (Ethereum).