Staking Rewards payout delays

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Sep 27, 2025 - 22:12 UTC

Monitoring

A fix has been implemented and we're monitoring the results.

All Staking Payouts should be completed in the next few hours.
Posted Sep 26, 2025 - 15:56 UTC

Investigating

We’re experiencing a delay in processing payouts for Staking Rewards.

Our team is actively working on a fix, and payouts will resume as soon as the issue is resolved.

We'll post updates as soon as we have them.
Posted Sep 26, 2025 - 11:20 UTC