Ethereum withdrawals delay
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Dec 30, 2021 - 21:40 UTC
Update
We are continuing to investigate this issue.
Posted Dec 29, 2021 - 21:05 UTC
Investigating
We are temporarily unable to process withdrawals to the Ethereum network.
Posted Dec 29, 2021 - 21:05 UTC
This incident affected: Crypto (Ethereum).