Card Transaction Issues for UK Users

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Sep 14, 2025 - 08:43 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2025 - 07:58 UTC

Investigating

We're currently investigating issues affecting some Uphold Card users in the UK following routine maintenance. Impacted users may experience declined transactions or difficulties using newly issued cards.

Our team is actively working to resolve the issue. We'll provide further updates as we make progress.

We apologize for the inconvenience and appreciate your patience.
Posted Sep 14, 2025 - 06:56 UTC
This incident affected: Uphold Debit Card.