We are temporarily not supporting DASH instant send deposits.
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Aug 31, 2022 - 16:22 UTC
Investigating
We are currently investigating this issue.
Posted Sep 09, 2021 - 17:04 UTC
This incident affected: Crypto (Dash).