Service Disruption: XRPL Network

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Dec 18, 2025 - 19:11 UTC

Investigating

We're experiencing issues processing Deposits and Withdrawals on the XRPL Network.

Our team is actively investigating to identify the root cause and restore normal operations as quickly as possible.

Products Affected:
- Uphold
- Topper

We’ll continue to provide updates as new information becomes available.

Thank you for your understanding.
Posted Dec 18, 2025 - 17:31 UTC
This incident affected: Deposits & Withdrawals and Topper.