Delayed BTC Transactions
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 12, 2019 - 19:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Jul 12, 2019 - 17:33 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Jul 12, 2019 - 16:47 UTC
Investigating
We are investigating delays with BTC transactions. We apologize for any inconvenience as we work to resolve the issue as quickly as possible.
Posted about 1 month ago. Jul 12, 2019 - 16:21 UTC
This incident affected: Deposits and Withdrawals.