UPBTC, UPCO2, VCO Withdrawals (UK only)

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Nov 22, 2023 - 14:04 UTC

Identified

A system issue is impacting withdrawals for the following assets, affecting UK users:
UPBTC, UPCO2, VCO

The team is working to resolve this issue ASAP. We apologize for any inconvenience and appreciate your patience.
Posted Oct 12, 2023 - 13:31 UTC
This incident affected: Deposits & Withdrawals.