Service disruption - Coreum & SOLO

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Mar 23, 2023 - 23:15 UTC

Monitoring

We are experiencing significant demand for the COREUM launch today. Our team is working to find additional supply, and we will open COREUM for purchases as it becomes available.
Posted Mar 23, 2023 - 16:05 UTC

Investigating

We're experiencing issues affecting buys for Coreum and SOLO.

The Team is investigating - we'll provide updates shortly.
Posted Mar 23, 2023 - 11:11 UTC
This incident affected: Mobile Wallet and Web Wallet.