Uphold Card outage

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Jan 01, 2025 - 14:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 01, 2025 - 13:38 UTC

Investigating

We are investigating an issue where Uphold Card payments are not being accepted.
Posted Jan 01, 2025 - 10:44 UTC
This incident affected: Uphold Debit Card.