XPD and XPT trading disabled
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Aug 23, 2021 - 08:39 UTC
Investigating
We are currently investigating this issue.
Posted Aug 22, 2021 - 16:47 UTC
This incident affected: Metals (Palladium, Platinum).