Delay in processing SEPA Instant Withdrawals
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Dec 23, 2020 - 22:44 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 23, 2020 - 21:45 UTC
Investigating
We are currently investigating this issue.
Posted Dec 23, 2020 - 20:34 UTC
This incident affected: National currencies (Euro).