Service Disruption | Transactions on Polygon network

Incident Report for Uphold

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 19:33 UTC

Investigating

We’re currently experiencing issues with the Polygon network, which are affecting transactions on both Uphold and Topper platforms.

Some transactions may appear pending or delayed. These will be processed once the underlying Polygon issue is resolved.

Our team is actively working to resolve the issue and expects to restore full service shortly.

We’ll continue to post updates here as more information becomes available.

Thank you for your patience and understanding. We apologize for any inconvenience caused.
Posted Jul 30, 2025 - 12:38 UTC
This incident affected: Deposits & Withdrawals and Topper.