Uphold Card - System issue
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Mar 20, 2023 - 17:27 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2023 - 17:14 UTC
Investigating
Due to a connection issue with our card processor, we're experiencing issues with the Uphold Card for the UK.

You may not be able to complete payments, order new cards or consult your Uphold Card details in-app.

We're investigating the issue and will provide updates once available.
Posted Mar 20, 2023 - 14:01 UTC
This incident affected: Mobile Wallet and Uphold Debit Card.