Deposit and Withdrawals delay
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Jun 17, 2020 - 14:36 UTC
Update
We are continuing to investigate this issue.
Posted Jun 17, 2020 - 12:34 UTC
Investigating
We're deploying an improvement in our platform that will cause delays on Deposits and Withdrawals, it should be resolved soon. Our apologies for any inconvenience.
Posted Jun 17, 2020 - 12:13 UTC