Mobile App loading issues
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Feb 13, 2020 - 18:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2020 - 15:59 UTC
Investigating
We are currently investigating this issue.
Posted Feb 13, 2020 - 15:15 UTC
This incident affected: Wallet.