Chat with us is unavailable
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Oct 20, 2021 - 08:59 UTC
Investigating
In app Chat functionality is currently not working. Attempts to engage via chat may not reach our Customer Service.
Posted Oct 19, 2021 - 22:15 UTC
This incident affected: Mobile Wallet.