Service Disruption: DAG & COQ

Incident Report for Uphold

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 29, 2026 - 09:03 UTC

Investigating

We are currently experiencing delays with Constellation (DAG) and Coq Inu (COQ) transactions affecting trading.

Our team is actively working to resolve the situation.

This issue impacts Uphold, Ascent, and Topper.

We apologize for any inconvenience and will provide updates as the situation progresses.
Posted May 29, 2026 - 08:43 UTC
This incident affects: Topper and Ascent.