We are investigating delays with XRP Deposits and Withdrawals. We apologize for any inconvenience as we work to resolve the issue as quickly as possible.
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Nov 25, 2021 - 17:37 UTC
Investigating
We are currently investigating this issue.
Posted Nov 25, 2021 - 17:18 UTC
This incident affected: Crypto (XRP).