COMP trading halted
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Sep 30, 2021 - 09:05 UTC
Investigating
We are currently investigating this issue.
Posted Sep 29, 2021 - 22:53 UTC
This incident affected: Crypto (Compound).