Delayed XRP Transactions
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Nov 21, 2021 - 23:24 UTC
Investigating
We are investigating delays with XRP transactions. We apologize for any inconvenience as we work to resolve the issue as quickly as possible.
Posted Nov 21, 2021 - 17:32 UTC
This incident affected: Crypto (XRP).