Delays in processing XRP deposits and withdrawals
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Mar 28, 2022 - 22:50 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2022 - 18:52 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 28, 2022 - 17:42 UTC
This incident affected: Crypto (XRP).