System Maintenance
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Feb 01, 2021 - 09:50 UTC
Identified
Uphold will be performing a system upgrade to increase the stability and performance of our platform. During this time, all services will be unavailable. We apologize for any inconvenience we should be back momentarily (10 minutes)
Posted Feb 01, 2021 - 09:42 UTC
This incident affected: Mobile Wallet, Web Wallet, and API.