Delayed BTC Transactions
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Dec 11, 2019 - 00:01 UTC
Investigating
We are investigating delays with BTC transactions. We apologize for any inconvenience as we work to resolve the issue as quickly as possible.
Posted Dec 10, 2019 - 19:13 UTC
This incident affected: Deposits and Withdrawals.