UPXAU Buys & Sells Disabled
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Aug 12, 2020 - 10:44 UTC
Update
We are continuing to investigate this issue.
Posted Aug 12, 2020 - 08:59 UTC
Investigating
We are currently investigating this issue.
Posted Aug 12, 2020 - 08:41 UTC
This incident affected: Metals (Gold) and Crypto (DigiByte).