Delayed XRP Transactions
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Nov 26, 2021 - 18:59 UTC
Update
We are continuing to investigate this issue.
Posted Nov 25, 2021 - 17:47 UTC
Investigating
We are investigating delays with XRP transactions. We apologize for any inconvenience as we work to resolve the issue as quickly as possible.
Posted Nov 25, 2021 - 17:46 UTC
This incident affected: Crypto (XRP).