Service currently unavailable
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted 18 days ago. Sep 26, 2019 - 22:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 18 days ago. Sep 26, 2019 - 22:16 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 18 days ago. Sep 26, 2019 - 22:11 UTC
Investigating
We are investigating issues in login to the platform via web and mobile.
Posted 18 days ago. Sep 26, 2019 - 21:57 UTC
This incident affected: API, Wallet, and Deposits and Withdrawals.