Unable to process DASH deposits and withdrawals
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Jan 14, 2020 - 09:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2020 - 00:23 UTC
Identified
We are currently unable to process DASH deposits and withdrawals
Posted Jan 13, 2020 - 17:32 UTC
This incident affected: Deposits and Withdrawals.