Delays with XRP Deposits & Withdrawals.
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Feb 09, 2021 - 10:49 UTC
Investigating
We are currently investigating this issue.
Posted Feb 09, 2021 - 10:03 UTC
This incident affected: Mobile Wallet and Web Wallet.