Delay in processing XRP withdrawals
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Aug 24, 2021 - 16:12 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2021 - 15:54 UTC
Investigating
We are currently investigating this issue.
Posted Aug 24, 2021 - 15:47 UTC
This incident affected: Crypto (XRP).