Delay in XRP deposits processing
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Aug 11, 2020 - 21:17 UTC
Investigating
We are currently investigating this issue.
Posted Aug 11, 2020 - 18:30 UTC
This incident affected: Crypto (XRP).