Delayed BTC Withdrawals
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted 3 months ago. May 15, 2019 - 16:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. May 15, 2019 - 16:22 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. May 15, 2019 - 15:08 UTC
Investigating
We are investigating delays with BTC transactions. We apologize for any inconvenience as we work to resolve the issue as quickly as possible.
Posted 3 months ago. May 15, 2019 - 14:30 UTC
This incident affected: Deposits and Withdrawals.