Delayed BTC, BTG, BCH, DASH and LTC Transactions
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Apr 14, 2021 - 23:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2021 - 22:04 UTC
Investigating
We are investigating delays with BTC, BTG, BCH, DASH and LTC transactions. We apologize for any inconvenience as we work to resolve the issue as quickly as possible.
Posted Apr 14, 2021 - 19:29 UTC
This incident affected: Crypto (Bitcoin, Bitcoin Cash, Bitcoin Gold, Dash, Litecoin).