Ethereum and ERC-20 token withdrawal delays
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Jun 30, 2022 - 09:53 UTC
Investigating
We are currently investigating this issue.
Posted Jun 29, 2022 - 19:51 UTC
This incident affected: Mobile Wallet, Web Wallet, API and Crypto (Ethereum).