We're experiencing delays in processing crypto withdrawals.
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Sep 11, 2021 - 17:31 UTC
Investigating
We are currently investigating this issue.
Posted Sep 09, 2021 - 08:23 UTC
This incident affected: Mobile Wallet, Web Wallet, and API.