Delay processing XRP deposits - We'll resume normal activity in a few hours
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Feb 04, 2021 - 21:54 UTC
Investigating
We are currently investigating this issue.
Posted Feb 04, 2021 - 17:10 UTC
This incident affected: Mobile Wallet and Web Wallet.