Delay in processing Withdrawals
Incident Report for Uphold
Resolved
This incident has been resolved.
Posted Aug 09, 2020 - 23:30 UTC
Investigating
We are currently investigating this issue.
Posted Aug 08, 2020 - 23:37 UTC
This incident affected: Utility Tokens (Basic Attention Token) and Crypto (Ethereum).